Notions générales

 

  • Syntaxe générale d’un algorithme
  • Entrées/Sorties
  • Opérations arithmétiuqes/logiques/tests
  • Affectations

Exemple 1 : Ecrire un algorithme, programme C & PHP qui permet de saisir la valeur des cotés d’un rectangle et d’afficher sa surface et son périmètre.

Algorithme : Exemple 1

Variables

longueur, largeur, surface, perimetre : réel

Début

Ecrire(« Saisir la longueur puis la largeur du rectangle »)

Lire(longueur)

Lire(largeur)

surface ← longueur * largeur

perimetre ← (longueur + largeur) * 2

Ecrire(« Surface du rectangle :  » + surface)

Ecrire(« Périmètre du rectangle :  » + perimetre)

Fin

Programme C : Cf partie exercices

Programme PHP : Cf partie exercices

Exemple 2 : Ecrire un algorithme, programme C & PHP qui permet de saisir le prix d’un produit, un nombre de produits et un taux de TVA et afficher le prix TTC et la part payée en TVA.

Algorithme : Exemple 2

Variables

prixProduit, tva, prixHT, prixTTC, partTVA : réel

nombreProduits : entier

Début

Ecrire(« Saisir le prix du produit et le nombre de produits achetés : « )

Lire(prixProduit)

Lire(nombreProduits)

Ecrire(« Saisir la valeur de la TVA : « )

Lire(tva)

prixHT ← prixProduit * nombreProduits

partTVA ← prixHT * (tva / 100)

prixTTC ← prixHT + partTVA

Ecrire(« Part de TVA :  » + partTVA)

Ecrire(« Prix TTC :  » + prixTTC)

Fin

Programme C : Cf partie exercices

Programme PHP : Cf partie exercices

 

 

Conditions

 

Exemple 3 : Ecrire un algorithme, programme C & PHP qui reçoit une adresse IP et affiche sa classe et son masque par défaut.

Algorithme : Exemple 3

Variables

Tableau Byte[4] : Entier

Début

Pour i de 0 à 4 faire

Ecrire(« Entrer l’octet  » + i)

Lire(Byte[i])

FinPour

Si Byte[0] < 128 alors

Ecrire(« IP de classe A – Masque par défaut : 255.0.0.0 »)

Sinon si Byte[0] < 191 alors

Ecrire(« IP de classe B – Masque par défaut : 255.255.0.0 »)

Sinon

Ecrire(« IP de classe C – Masque par défaut : 255.255.255.0 »)

FinSi

Fin

Programme C : Cf partie exercices (Utilisation de formatage du scanf)

Programme PHP : Cf partie exercices